サイト制作に関するメモ書き

HOME > その他 > gulp-sass実行時にSyntaxErrorになる

gulp-sass実行時にSyntaxErrorになる

恐らくgulp-sassに限らなそうですが、gulp-sass実行時に「SyntaxError: Block-scoped declarations (let, const, function, class) not yet supported outside strict mode」とエラーが出ることがあったので、対応方法を調べました。

原因

使用していたNodeのバージョンが4.9.1だったのですが、Nodeのバージョンが4系だと出るようです。
今回Nodeのバージョン管理にnodistを入れていたので、試しにバージョンを6.14.2に変更してたところ、エラーは出なくなりました。

nodistについては以前記事を投稿していますので、そちらを参照ください。
Node.jsのバージョン管理にnodistを使ってみる
 

もしくは、gulp-sassのバージョンを下げる形でも対応できるようです。
元々4.0.1を使用していたのを3.2.1に変更しても、エラーは出なくなりました。

package.json

"gulp-sass": "^4.0.1"
↓
"gulp-sass": "^3.2.1"

 

【参考サイト】

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

▲PAGE TOP